<?xml version="1.0"?>
<feed xmlns="http://www.w3.org/2005/Atom" xml:lang="es">
	<id>https://manuais.iessanclemente.net/index.php?action=history&amp;feed=atom&amp;title=Servizo_de_correo-e</id>
	<title>Servizo de correo-e - Historial de revisiones</title>
	<link rel="self" type="application/atom+xml" href="https://manuais.iessanclemente.net/index.php?action=history&amp;feed=atom&amp;title=Servizo_de_correo-e"/>
	<link rel="alternate" type="text/html" href="https://manuais.iessanclemente.net/index.php?title=Servizo_de_correo-e&amp;action=history"/>
	<updated>2026-10-21T05:07:56Z</updated>
	<subtitle>Historial de revisiones de esta página en la wiki</subtitle>
	<generator>MediaWiki 1.46.2</generator>
	<entry>
		<id>https://manuais.iessanclemente.net/index.php?title=Servizo_de_correo-e&amp;diff=10427&amp;oldid=prev</id>
		<title>Arribi: /* Instalación dun servidor POP/IMAP */</title>
		<link rel="alternate" type="text/html" href="https://manuais.iessanclemente.net/index.php?title=Servizo_de_correo-e&amp;diff=10427&amp;oldid=prev"/>
		<updated>2009-03-16T12:19:38Z</updated>

		<summary type="html">&lt;p&gt;&lt;span class=&quot;autocomment&quot;&gt;Instalación dun servidor POP/IMAP&lt;/span&gt;&lt;/p&gt;
&lt;p&gt;&lt;b&gt;Página nueva&lt;/b&gt;&lt;/p&gt;&lt;div&gt;=Introdución=&lt;br /&gt;
O correo-e é un dos servizo máis usados en Internet. Para poder enviar e recibir correo-e úsanse diferentes protocolos. Para o envío úsase &amp;#039;&amp;#039;&amp;#039;SMTP&amp;#039;&amp;#039;&amp;#039; e para a recepción &amp;#039;&amp;#039;&amp;#039;POP3&amp;#039;&amp;#039;&amp;#039; ou &amp;#039;&amp;#039;&amp;#039;IMAP4&amp;#039;&amp;#039;&amp;#039;.&lt;br /&gt;
&lt;br /&gt;
=O Simple Mail Transfer Protocol=&lt;br /&gt;
[[Image:aplicacion12.jpg|right]]Este protocolo está especificado no RFC 2821. O modelo de correo-e para o envío está formado por tres elementos principais: &lt;br /&gt;
*Axente de correo de usuario ou MUA: é o cliente de correo e permite redactar, gardar, ler e enviar as mensaxes. i.e: Thunderbird, Eudora, Outlook, etc. &lt;br /&gt;
*Servidores de correo : as mensaxes enviadas e recibidas almacénanse no servidor ao que tamén se lle chama MTA (&amp;#039;&amp;#039;Mail Transfer Agent&amp;#039;&amp;#039;). Os buzóns nos servidores conteñen as mensaxes enviadas aos usuarios. As colas de mensaxes conteñen as mensaxes que envían os usuarios (son as mensaxes que van ser enviadas).&lt;br /&gt;
*Protocolo simple de transferencia de correo (&amp;#039;&amp;#039;Simple Mail Transfer Protocol&amp;#039;&amp;#039; ou SMTP): o protocolo SMTP permite enviar os correos entre servidores. Funciona como cliente e como servidor:&lt;br /&gt;
**Cliente: envía correo a outro servidor SMTP&lt;br /&gt;
**Servidor: recibe correo doutro servidor SMTP&lt;br /&gt;
&lt;br /&gt;
SMTP usa TCP para enviar de xeito fiable os correos desde o cliente ao servidor (porto 25). A conexión TCP é persistente. Funciona mediante tres pasos:&lt;br /&gt;
#Apertura (&amp;#039;&amp;#039;handshaking&amp;#039;&amp;#039;)&lt;br /&gt;
#Transferencia do correo&lt;br /&gt;
#Peche&lt;br /&gt;
A interacción entre o axente de usuario e o servidor é mediante comando/resposta. Os comandos son texto ASCII e as respostas a eses comandos inclúen un código de estado e unha frase explicativa. A transferencia do correo faise directamente entre os dous servidores SMTP. As mensaxes deben estar en ASCII de 7 bit, aínda que esta é unha restrición arcaica herdada dos primeiros anos nos que se deseñou ao protocolo, hoxe en día superada como veremos máis adiante.&lt;br /&gt;
&lt;br /&gt;
Na seguinte figura podemos ver un exemplo de envío de correo-e no que Ana envía un mail a Fran:&lt;br /&gt;
[[Image:aplicacion13.jpg|center]]&lt;br /&gt;
Os pasos que se seguen son os seguinteS:&lt;br /&gt;
#Ana usa un axente de usuario (MUA) para compoñer unha mensaxe para fran@instituto.edu&lt;br /&gt;
#O MAU de Ana envía a mensaxe ao seu servidor de correo; a mensaxe colócase na cola de mensaxes&lt;br /&gt;
#A parte cliente do SMTP de Ana abre unha conexión TCP co servidor SMTP de Fran&lt;br /&gt;
#A parte cliente do SMTP de Ana envía o correo sobre unha conexión TCP (previamente fai o handshake) &lt;br /&gt;
#O servidor SMTP de Fran coloca o correo no seu buzón&lt;br /&gt;
#Fran abre o seu cliente de correo para poder descargar e ler as mensaxes do seu buzón&lt;br /&gt;
&lt;br /&gt;
A continuación amósase un exemplo de interacción SMTP entre un cliente (C) e un servidor (S):&lt;br /&gt;
&amp;lt;code&amp;gt;&lt;br /&gt;
     S: 220 servidor.edu &lt;br /&gt;
     C: &amp;#039;&amp;#039;&amp;#039;HELO&amp;#039;&amp;#039;&amp;#039; cliente.fr &lt;br /&gt;
     S: 250  Hello cliente.fr, pleased to meet you &lt;br /&gt;
     C: &amp;#039;&amp;#039;&amp;#039;MAIL FROM:&amp;#039;&amp;#039;&amp;#039; &amp;lt;ana@cliente.fr&amp;gt; &lt;br /&gt;
     S: 250 ana@cliente.fr... Sender ok &lt;br /&gt;
     C: &amp;#039;&amp;#039;&amp;#039;RCPT TO:&amp;#039;&amp;#039;&amp;#039; &amp;lt;fran@servidor.edu&amp;gt; &lt;br /&gt;
     S: 250 fran@servidor.edu ... Recipient ok &lt;br /&gt;
     C: &amp;#039;&amp;#039;&amp;#039;DATA&amp;#039;&amp;#039;&amp;#039; &lt;br /&gt;
     S: 354 Enter mail, end with &amp;quot;.&amp;quot; on a line by itself &lt;br /&gt;
     C: Quedamos hoxe? &lt;br /&gt;
     C: A que hora e onde? &lt;br /&gt;
     C: &amp;#039;&amp;#039;&amp;#039;.&amp;#039;&amp;#039;&amp;#039; &lt;br /&gt;
     S: 250 Message accepted for delivery &lt;br /&gt;
     C: &amp;#039;&amp;#039;&amp;#039;QUIT&amp;#039;&amp;#039;&amp;#039; &lt;br /&gt;
     S: 221 servidor.edu closing connection&lt;br /&gt;
&amp;lt;/code&amp;gt;&lt;br /&gt;
&lt;br /&gt;
=O formato dunha mensaxe de correo=&lt;br /&gt;
[[Imagen:UD7_1.jpg|right]]No RFC 822 defínese o estándar para o formato das mensaxes de texto do correo electrónico. Estas mensaxes están formadas por unha cabececeira e un corpo da mensaxe.&lt;br /&gt;
&lt;br /&gt;
A liña da cabeceira pode conter diferentes campos, por exemplo:&lt;br /&gt;
*&amp;#039;&amp;#039;&amp;#039;To:&amp;#039;&amp;#039;&amp;#039; ou &amp;#039;&amp;#039;&amp;#039;A:&amp;#039;&amp;#039;&amp;#039;, que é obrigatorio e indica a quen vai dirixida a mensaxe.&lt;br /&gt;
*&amp;#039;&amp;#039;&amp;#039;From:&amp;#039;&amp;#039;&amp;#039; ou &amp;#039;&amp;#039;&amp;#039;De:&amp;#039;&amp;#039;&amp;#039;, que tamén é obrigatorio e indica o remitente.&lt;br /&gt;
*&amp;#039;&amp;#039;&amp;#039;Subject:&amp;#039;&amp;#039;&amp;#039; ou &amp;#039;&amp;#039;&amp;#039;Asunto:&amp;#039;&amp;#039;&amp;#039;, que é opcional e indica o motivo da mensaxe.&lt;br /&gt;
O Corpo é o texto do correo, en ASCII.&lt;br /&gt;
==Extensións multimedia==&lt;br /&gt;
Para poder enviar mensaxes que conteñan datos de tipo multimedia definíronse os tipos MIME (&amp;#039;&amp;#039;Multipurpose Internet Mail Extensions&amp;#039;&amp;#039;), que determinan as extensións multimedia para o correo e que están especificadas nos RFC 2045 e RFC 2056.&lt;br /&gt;
&lt;br /&gt;
As extensións multimedia definen liñas adicionais na cabeceira da mensaxe que especifican o tipo de contido MIME, tal e como se ve no seguinte exemplo:&lt;br /&gt;
&lt;br /&gt;
[[Imagen:UD7_2.jpg|center]]&lt;br /&gt;
&lt;br /&gt;
=Protocolos de acceso ao correo=&lt;br /&gt;
Con SMTP podemos envíar e almacenar os correos recibidos. Para poder descargalos do noso buzón precísase un protocolo de acceso ao correo específico.&lt;br /&gt;
[[Imagen:UD7_4.jpg|center]]&lt;br /&gt;
Temos tres posibilidades, POP, IMAP e HTTP. Ao software encargada de realizar as funcións de distribución de correo chámaselle &amp;#039;&amp;#039;Mail Delivery Agent&amp;#039;&amp;#039; ou MDA.&lt;br /&gt;
==POP ou &amp;#039;&amp;#039;Post Office Protocol&amp;#039;&amp;#039;==&lt;br /&gt;
Está especificado no RFC 1939. Funciona mediante unha autorización previa (axente &amp;lt;--&amp;gt;servidor) e posterior descarga. Durante a fase de autorización os comandos do cliente poden ser:&lt;br /&gt;
*&amp;#039;&amp;#039;&amp;#039;user&amp;#039;&amp;#039;&amp;#039;: nome de usuario&lt;br /&gt;
*&amp;#039;&amp;#039;&amp;#039;pass&amp;#039;&amp;#039;&amp;#039;: password&lt;br /&gt;
E as respostas do servidor:&lt;br /&gt;
*&amp;#039;&amp;#039;&amp;#039;+OK&amp;#039;&amp;#039;&amp;#039;&lt;br /&gt;
*&amp;#039;&amp;#039;&amp;#039;-ERR&amp;#039;&amp;#039;&amp;#039;&lt;br /&gt;
Durante a fase de transacción algúns comandos do cliente poden ser os seguintes:&lt;br /&gt;
*&amp;#039;&amp;#039;&amp;#039;list&amp;#039;&amp;#039;&amp;#039;: lista os nº dos correos&lt;br /&gt;
*&amp;#039;&amp;#039;&amp;#039;retr&amp;#039;&amp;#039;&amp;#039;: obtén un correo&lt;br /&gt;
*&amp;#039;&amp;#039;&amp;#039;dele&amp;#039;&amp;#039;&amp;#039;: borra un correo&lt;br /&gt;
*&amp;#039;&amp;#039;&amp;#039;quit&amp;#039;&amp;#039;&amp;#039;: sae da sesión&lt;br /&gt;
A continuación amósase un exemplo de interacción entre un cliente (C) e un sevidor (S) con este protocolo:&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
S: +OK POP3 servidor listo&lt;br /&gt;
C: user fran &lt;br /&gt;
S: +OK &lt;br /&gt;
C: pass claveexemplo &lt;br /&gt;
S: +OK user successfully logged on&lt;br /&gt;
&lt;br /&gt;
C: list &lt;br /&gt;
S: 1 498 &lt;br /&gt;
S: 2 912 &lt;br /&gt;
S: . &lt;br /&gt;
C: retr 1 &lt;br /&gt;
S: &amp;lt;contido correo 1&amp;gt;&lt;br /&gt;
S: . &lt;br /&gt;
C: dele 1 &lt;br /&gt;
C: retr 2 &lt;br /&gt;
S: &amp;lt;contido correo 2&amp;gt;&lt;br /&gt;
S: . &lt;br /&gt;
C: dele 2 &lt;br /&gt;
C: quit &lt;br /&gt;
S: +OK POP3 server signing off&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
O exemplo anterior usa o modo “descarga e borrado”, polo tanto, o usuario non pode reler o correo se cambia de cliente. Existe o modo “descarga e mantén“que permite descargar o mesmo correo en clientes distintos.&lt;br /&gt;
&lt;br /&gt;
==IMAP ou &amp;#039;&amp;#039;Internet Mail Access Protocol&amp;#039;&amp;#039;==&lt;br /&gt;
Está especificado no RFC 1730. É posterior ao POP e ten máis características, polo tanto, é máis complexo. Permite a manipulación dos correos almacenados no servidor, manténdoos centralizados. Permite ao usuario organizar correos en directorios, así como facer buscas. Outra característica importante é que permite descargar partes das mensaxes, por exemplo, só o texto do correo e non os adxuntos.&lt;br /&gt;
&lt;br /&gt;
==Webmail==&lt;br /&gt;
Permite o acceso ao correo mediante a un navegador Web. Exemplos deste tipo de acceso son Gmail, Hotmail, Yahoo! Mail, etc. É un servizo cada vez máis usado pola súa comodidade.&lt;br /&gt;
&lt;br /&gt;
O Axente de Usuario é un navegador Web e no servidor web fai falta software específico (i.e: squirrel mail)&lt;br /&gt;
O usuario accede ao seu correo no servidor vía HTTP, no canto de usar POP3 ou IMAP. Para enviar o correo tamén se usa HTTP, no canto de SMTP, pero a comunicación entre servidores é mediante SMTP.&lt;br /&gt;
=Instalación dun servidor SMTP=&lt;br /&gt;
Existen moitos programas que fan de servidor de correo saínte (Postfix, Qmail, Exim, etc.). Postfix caracterízase por ser potente, fácil de configurar e seguro. Por iso é o que se usará. Para instalar o programa en Ubuntu tecléase o seguinte:&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
sudo apt-get install postfix&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
Durante a instalación aparecerán varias pantallas de configuración. Na primeira delas hai que escoller a opción Sitio de Internet. A continuación hai que escoller o nome de correo do sistema. Este nome debe ser o nome completo de dominio (FQDN). Por exemplo, se un enderezo de correo no servidor local fose alumno1@2esi.org, o valor correcto para esta opción será 2esi.org. &lt;br /&gt;
&lt;br /&gt;
Pódese comprobar que o servidor está executándose tecleando:&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
netstat -tl&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
Outra forma de velo e facendo unha conexión mediante o comando telnet ao porto 25 da máquina e interactuar co servidor que acabas de instalar introducindo os [[Servizo_de_correo-e#Introduci.C3.B3n|comandos correspondentes]].&lt;br /&gt;
&lt;br /&gt;
=Instalación dun servidor POP/IMAP=&lt;br /&gt;
Existen moitos programas que fan de servidor de correo saínte (Cyrus, Courier, etc.). Nós instalaremos o  Dovecot que fará de servidor POP e IMAP. Para iso hai que teclear nunha consola o seguinte:&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
sudo apt-get install dovecot-imapd dovecot-pop3d&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
Se se executa o comando netstat -tl vese que se instalaron os servizos POP e IMAP e tamén as súas versións segurar, é dicir, POPS e IMAPS.&lt;br /&gt;
Pódese comprobar o funcionamento do servizo facendo unha conexión mediante o comando telnet ao porto 110 da máquina (se usamos POP) e interactuar co servidor que se acaba de instalar introducindo os comandos correspondentes do protocolo.&lt;br /&gt;
&lt;br /&gt;
--[[Usuario:Arribi|Arribi]] 12:01 16 mar 2009 (GMT)&lt;/div&gt;</summary>
		<author><name>Arribi</name></author>
	</entry>
</feed>