<?xml version="1.0"?>
<feed xmlns="http://www.w3.org/2005/Atom" xml:lang="es">
	<id>https://manuais.iessanclemente.net/index.php?action=history&amp;feed=atom&amp;title=OpenSSH</id>
	<title>OpenSSH - Historial de revisiones</title>
	<link rel="self" type="application/atom+xml" href="https://manuais.iessanclemente.net/index.php?action=history&amp;feed=atom&amp;title=OpenSSH"/>
	<link rel="alternate" type="text/html" href="https://manuais.iessanclemente.net/index.php?title=OpenSSH&amp;action=history"/>
	<updated>2026-10-24T02:03:28Z</updated>
	<subtitle>Historial de revisiones de esta página en la wiki</subtitle>
	<generator>MediaWiki 1.46.2</generator>
	<entry>
		<id>https://manuais.iessanclemente.net/index.php?title=OpenSSH&amp;diff=60583&amp;oldid=prev</id>
		<title>Vieites en 08:05 12 sep 2016</title>
		<link rel="alternate" type="text/html" href="https://manuais.iessanclemente.net/index.php?title=OpenSSH&amp;diff=60583&amp;oldid=prev"/>
		<updated>2016-09-12T08:05:14Z</updated>

		<summary type="html">&lt;p&gt;&lt;/p&gt;
&lt;p&gt;&lt;b&gt;Página nueva&lt;/b&gt;&lt;/p&gt;&lt;div&gt;{{En_Construcion}}&lt;br /&gt;
== Introdución ao servidor OpenSSH ==&lt;br /&gt;
&amp;#039;&amp;#039;&amp;#039;OpenSSH (&amp;#039;&amp;#039;Secure Shell&amp;#039;&amp;#039;, Entorno Seguro)&amp;#039;&amp;#039;&amp;#039; é un paquete que contén un grupo de programas para a transferencia remota segura:&lt;br /&gt;
* &amp;#039;&amp;#039;&amp;#039;scp (&amp;#039;&amp;#039;Secure Copy&amp;#039;&amp;#039;, Copia segura).&amp;#039;&amp;#039;&amp;#039;&lt;br /&gt;
* &amp;#039;&amp;#039;&amp;#039;ssh (&amp;#039;&amp;#039;Secure Shell&amp;#039;&amp;#039;, Intérprete de comandos seguro).&amp;#039;&amp;#039;&amp;#039;&lt;br /&gt;
* &amp;#039;&amp;#039;&amp;#039;sftp (SSH &amp;#039;&amp;#039;file transfer protocol&amp;#039;&amp;#039;, Protocolo de transferencia de arquivos sobre SSH).&amp;#039;&amp;#039;&amp;#039;&lt;br /&gt;
&lt;br /&gt;
&amp;#039;&amp;#039;&amp;#039;ssh&amp;#039;&amp;#039;&amp;#039; é a ferramenta a elixir para a administración remota do sistema. Poderemos iniciar sesión en sistemas remotos e executalos coma si estivésemos fisicamente neles. O inicio de sesión e os datos cífranse e compróbase se os arquivos enviados foron alterados durante a transferencia.&lt;br /&gt;
&lt;br /&gt;
En realidade SSH non é un intérprete de comandos, SSH é un protocolo. Hai dúas versións incompatibles entre si: &amp;#039;&amp;#039;&amp;#039;SSH-1&amp;#039;&amp;#039;&amp;#039; e &amp;#039;&amp;#039;&amp;#039;SSH-2&amp;#039;&amp;#039;&amp;#039;. &lt;br /&gt;
&lt;br /&gt;
Na actualidade emprégase SSH-2 que está descrito en 5 documentos: &lt;br /&gt;
:* &amp;#039;&amp;#039;&amp;#039;SSH &amp;#039;&amp;#039;Assigned Numbers&amp;#039;&amp;#039; (RFC 4250)&amp;#039;&amp;#039;&amp;#039;&lt;br /&gt;
:* &amp;#039;&amp;#039;&amp;#039;SSH &amp;#039;&amp;#039;Protocol Architecture&amp;#039;&amp;#039; (RFC 4251)&amp;#039;&amp;#039;&amp;#039;&lt;br /&gt;
:* &amp;#039;&amp;#039;&amp;#039;SSH &amp;#039;&amp;#039;Authentication Protocol&amp;#039;&amp;#039; (RFC 4252)&amp;#039;&amp;#039;&amp;#039;&lt;br /&gt;
:* &amp;#039;&amp;#039;&amp;#039;SSH &amp;#039;&amp;#039;Transport Layer Protocol&amp;#039;&amp;#039; (RFC 4253)&amp;#039;&amp;#039;&amp;#039;&lt;br /&gt;
:* &amp;#039;&amp;#039;&amp;#039;SSH &amp;#039;&amp;#039;Connection Protocol&amp;#039;&amp;#039; (RFC 4254)&amp;#039;&amp;#039;&amp;#039; &lt;br /&gt;
&lt;br /&gt;
== Instalación do servidor SSH ==&lt;br /&gt;
Instalamos o servidor &amp;#039;&amp;#039;&amp;#039;OpenSSH&amp;#039;&amp;#039;&amp;#039;.&lt;br /&gt;
Por exemplo, para instalalo nunha distribución Ubuntu:&lt;br /&gt;
&amp;lt;source lang=&amp;quot;bash&amp;quot;&amp;gt;&lt;br /&gt;
# apt-get install openssh-server&lt;br /&gt;
&amp;lt;/source&amp;gt;&lt;br /&gt;
== Arrancar o servidor SSH ==&lt;br /&gt;
O demo de SSH é &amp;#039;&amp;#039;sshd&amp;#039;&amp;#039;.&lt;br /&gt;
Para iniciar sshd:&lt;br /&gt;
&amp;lt;source lang=&amp;quot;bash&amp;quot;&amp;gt;&lt;br /&gt;
# /etc/init.d/sshd start&lt;br /&gt;
&amp;lt;/source&amp;gt;&lt;br /&gt;
Para deter sshd:&lt;br /&gt;
&amp;lt;source lang=&amp;quot;bash&amp;quot;&amp;gt;&lt;br /&gt;
# /etc/init.d/sshd stop&lt;br /&gt;
&amp;lt;/source&amp;gt;&lt;br /&gt;
Así e todo, o mellor é comprobar os nomes dos arquivos &amp;#039;&amp;#039;init&amp;#039;&amp;#039;, pois poden variar segundo a distribución.&lt;br /&gt;
&lt;br /&gt;
== Agregar seguridade ao servidor SSH ==&lt;br /&gt;
[https://help.ubuntu.com/community/AdvancedOpenSSH Enlace de interese para a distribución Ubuntu].&lt;br /&gt;
&lt;br /&gt;
É interesante aumentar a seguridade do servidor, para iso editaremos o arquivo /etc/ssh/sshd_config e cambiaremos ou engadiremos as seguintes liñas:&lt;br /&gt;
=== Cambiar o porto por defecto ===&lt;br /&gt;
Por defecto o SSH escoita no porto 22, é interesante cambialo por un que só nos saibamos. Por exemplo, para facer que escoite no porto 1122 engadiremos a directiva &amp;#039;&amp;#039;&amp;#039;Port&amp;#039;&amp;#039;&amp;#039;:&lt;br /&gt;
&amp;lt;source lang=&amp;quot;bash&amp;quot;&amp;gt;&lt;br /&gt;
Port 1122&lt;br /&gt;
&amp;lt;/source&amp;gt;&lt;br /&gt;
&lt;br /&gt;
== Conexión dende un PC con Windows ==&lt;br /&gt;
O mellor neste caso é empregar o software [http://www.chiark.greenend.org.uk/~sgtatham/putty/ PuTTY].&lt;br /&gt;
&lt;br /&gt;
O único que hai que facer é descargalo, instalalo e executalo. Despois debe de escribirse o nome, ou a IP, do ordenador ó que se quere conectar, e logo facer clic en Open.&lt;br /&gt;
&lt;br /&gt;
O programa é un executable (putty.exe), colle en calquera disquete e pode executarse dende unha memoria USB, disquete ou similar.&lt;br /&gt;
&lt;br /&gt;
Para acceder dende Windows tamén poderíamos utilizar o [http://www.cygwin.com/ Cygwin].&lt;br /&gt;
&lt;br /&gt;
*: &amp;#039;&amp;#039;&amp;#039;Ligazón de Interese:&amp;#039;&amp;#039;&amp;#039; [http://informatica.iessanclemente.net/manuais/index.php/Exemplo_1._Distribuci%C3%B3n_Live_SystemRescueCD._Conexi%C3%B3n_ao_seu_servidor_SSH_e_configuraci%C3%B3n_do_mesmo#Conexi.C3.B3n_mediante_o_cliente_gr.C3.A1fico_putty_para_plataformas_Windows_e_UNIX Putty para plataformas Windows e UNIX]&lt;br /&gt;
&lt;br /&gt;
== Exemplos conexión SSH ==&lt;br /&gt;
&lt;br /&gt;
Ligazón [http://informatica.iessanclemente.net/manuais/index.php/Ferramentas_de_diagn%C3%B3stico_e_control_remoto#Exemplos_conexi.C3.B3n_SSH Exemplos]&lt;/div&gt;</summary>
		<author><name>Vieites</name></author>
	</entry>
</feed>